So i run windows Server 2008 (Windows Vista shell) for workstation purposes on my main computer (3d graphic rendering, video compiling, stuff like that), and i normally just run Bonetown on my laptop, abliet not super well, but playable.

My problem is, Bonecraft is not even playable on my laptop, it is a bit underpowered so i went to give it a play on my main system, with no success. when i try to launch the program i get the following app crash faults:

Problem signature:
Problem Event Name: APPCRASH
Application Name: BoneCraft.exe
Application Version:
Application Timestamp: 00000000
Fault Module Name: BoneCraft.exe
Fault Module Version:
Fault Module Timestamp: 00000000
Exception Code: c000001d
Exception Offset: 007cbdfd
OS Version: 6.0.6002.
Locale ID: 1033
Additional Information 1: a2fa
Additional Information 2: 0d6a30f8ef45c0aa96bcbe38c5bc5dbf
Additional Information 3: f6f8
Additional Information 4: 77b2ff44e929070c9c6db160e3b35e95

i get this as soon as i try to launch the game, i've tried compatibility settings, running as admin, several combinations of that. updating windows, and video card drivers (Nvidia GTX 470).

So is there something i can do to get this to run, or am i pretty much out of luck untill i get a system that has a consumer level of windows running on it?