View Full Version : Can't write license data

12-17-2011, 09:29 PM
I have written several times to tech support, but other than a reply the 1st time, which didn't fix the problem, not a word since.

Have the game installed on my laptop, and want to install it on my desktop. I read you are allowed to do this. However, when I did the install on the desk top, and started the game, I got a message saying it can't write license data, and quits trying to start.

I wouldn't really mind, but wife will be taking laptop with her, for 3 weeks of training. So won't have game available, if I can't get it to run on desktop.

I did uninstall it, and did another install, but no go.

Any suggestions?

12-18-2011, 02:52 AM
Obviously, I am not any kind of "official" support, but I may have some things for you to try (if you haven't done some of these things already, that is).

But first, a question...are you installing BoneTown from the retail disc or from DD (Digital Download) form? I ask this because I know the DD version needs its serial number verified before playing the first time and although you can have the game installed on multiple PCs, I believe you have to "deactivate" the one you're not planning on playing on so you can "activate" the other one. There should be a shortcut called "Revoke Activation" from the BoneTown programs group (at your PC's desktop, click on Start, highlight the BoneTown programs group, and the shortcut should be there). If you are installing/playing from disc then you can ignore the whole activation process since it will simply do a disc check before launching the game if you skip activation.

You may also want to make sure all active programs running in the background like virus scanners and such are disabled before installing. It may not prompt any errors, but sometimes these programs think an undesireable change is being made to your PC and in the end prevents an installation from completing correctly.

Another couple of things that may help is trying running the BoneTown installation as an adminstrator and/or try installing the game outside of the Program Files directory it defaults to (if you're using a 64-bit version of Windows, as I'm currently am, the default directory is called "Program Files (x86)"). But in any case, try installing with a new directory path like C:\Games\BoneTown or whatever fits your needs and see if that helps.

12-18-2011, 10:39 AM
Please try TheMadCow's suggestions, if they do not work please let us know and we can help you further. Thanks TMC for the reply, very helpful!

12-20-2011, 11:41 AM
Thanks, TMC and D-Dub, but no joy. I'm running it from the download version. It did have the deactivate links, but says it can't do it, and have found no way around that. I deleted the program, and ran a cleaner. Then made sure any background programs where shut down. Did a new install, to a new directory. Got same 'Can't write licensing data' message as before.

Anything else I might try?

Thanks again.

12-20-2011, 04:26 PM
Doing a couple searches of "Can't write license data" on Google came up with SecuROM as being the most likely culprit in regards to this error message (though in the searches the games in question that people were having trouble running were Bioshock, Sims 2, Battlefield 2, etc.).

Checking out SecuROM's site, I found that they have a removal tool which supposedly clears all licenses/activations/etc. from your Windows installation (I'm assuming this would include "all" the software that uses SecuROM that you may have installed). Then supposedly once you relaunch the application which was giving you the error, it should re-create the necessary license data to load properly.

But before I can even suggest to try running the tool, I'd suggest we wait and see if D-Dub can agree that it could be a SecuROM issue (I hate to be the one to suggest something that could possibly make things worse for you, so I want to be cautious in this regard).

Also, you mentioned that you cannot run the "Revoke Activation" link. Are you doing this from the installation you are trying to get working, or from the computer where the game was originally installed? You want to be executing the "Revoke Activation" link from the original installation, since by my understanding on how this whole system works, you're temporarily deactivating one installation to be able to activate a new one on a different computer when you install.

And in case you're interested in reading up on it, here's the link to the SecuROM removal tool I mentioned earlier:

SecuROM Removal Tool (https://support.securom.com/removaltool.html)

But, as I also mentioned earlier, I'd suggest we see if SecuROM could be the cause of the issue since running that tool could possibly affect more programs that you may have installed on your computer.

12-21-2011, 04:43 AM
Here's the background. I bought the game as a download, to my laptop, and installed it there, while on the road. When I got home, I installed it from same d/l link as original, to the desktop. Installation went fine, but when I launched the game, I got a message "License Activation failed". So I did a uninstall, and tried installing it again. This time, i got the "can't write license data" message. I only did it because I had read that you can put it on up to 2 computers, and since laptop will be traveling with wife, figured I'd have it on desktop, to play.

Thanks for the suggestion about SecuROM, but yeah, will wait and see what D-DUB says.

12-21-2011, 02:50 PM
This issue has been resolved through PM. If any one else has this issue please post in this thread.

01-09-2012, 12:42 PM
I am having the same issue. How was this resolved?

12-18-2012, 07:24 PM
I too am having the same issue, and it's the first install anywhere

12-25-2012, 07:09 AM
Can't install the game - it says too many activations.
My previous system where game was installed crashed completely due to dead SSD quite a long time ago. I have made a complete upgrade since then - motherboard, cpu, SSDs.
I can not revoke my activation, obviously - all data from old system are gone, and i can not manually activate on SecuROM site - it says "too many activations!"

Please help!

Game order number is 1800, placed on 1/5/2009


It took a while, but my case has been solved. THANK YOU D-DUB for your support!